. bee blog: Dynamic Routing

Dynamic Routing

DYNAMIC ROUTING
PENGERTIAN
Dynamic routing adalah fungsi dari routing protocol yang berkomunikasi dengan router yang lain untuk saling meremajakan (update) tabel routing yang ada. Dengan demikian, administrator tidak perlu melakukan updating jalur (path) jika terjadi perubahan jalur transmisi (path). Dynamic routing umumnya digunakan untuk jaringan komputer yang besar dan lebih kompleks.
Dynamic routing di bagi menjadi 2, yaitu:
1. Interior Gateway Protokol
2. Exterior Gateway Protokol
Open Shortest Path First (OSPF) adalah routing dinamic yang masing router memiliki tabel daftar ID dari router-reiuter yang terkoneksi. Jalan yang akan di lalui adalah route yang nilainya terpendek (sesuai dengan namanya). Routing model ini termasuk smart route karena jika terputus akan mencari jalan lain secara otomatis.
Interior Gateway Routing Protocol (IGRP) adalah routing protokol distance vector yang dibuat oleh Cisco. IGRP mengirimkan update routing setiap interval 90 detik. Update ini advertise semua jaringan dalam AS.
Routing Information Protocol (RIP) adalah protokol routing dinamik yang berbasis distance vector. RIP menggunakan protokol UDP pada port 520 untuk mengirimkan informasi routing antar router. RIP menghitung routing terbaik berdasarkan perhitungan HOP. RIP membutuhkan waktu untuk melakukan converge. RIP membutuhkan power CPU yang rendah dan memory yang kecil dari pada protocol yang lainnya.

KONFIGURASI

KONFIGURASI ROUTER1
R1(config)#int s1/0
R1(config-if)#ip address 202.110.10.1 255.255.255.0
R1(config-if)#clock rate 128000
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int f0/1
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 192.168.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#network 202.110.10.0
R1(config-router)#network 172.16.0.0
R1(config-router)#network 172.18.0.0
R1(config-router)#network 172.30.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#end
R1#wr mem // ini adalah perintah untuk menyimpan konfigurasi router kedalam IOS //
R1#sh ip int brief // ini adalah perintah untuk melihat status interface sudah UP atau belum //
R1#sh ip route // ini adalah perintah untuk melihat rute jalur routingnya //
R1#ping 10.0.0.1

KONFIGURASI ROUTER2
R2(config)#int s1/0
R2(config-if)#ip ad
R2(config-if)#ip address 202.110.10.2 255.255.255.0
R2(config-if)#clock rate 128000
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int s1/1
R2(config-if)#ip ad
R2(config-if)#ip address 172.18.0.1 255.255.0.0
R2(config-if)#clock rate 128000
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip ad
R2(config-if)#ip address 172.16.0.1 255.255.0.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 172.16.0.0
R2(config-router)#network 202.110.10.0
R2(config-router)#network 172.18.0.0
R2(config-router)#network 192.168.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#network 10.0.0.0
R2(config)#end
R2#wr mem // ini adalah perintah untuk menyimpan konfigurasi router kedalam IOS //
R2#sh ip route

KONFIGURASI ROUTER3
Router>ena
Router#conf t
Router(config)#hos
Router(config)#hostname R3
R3(config)#int s1/0
R3(config-if)#ip ad
R3(config-if)#ip address 172.18.0.1 255.255.0.0
R3(config-if)#clock rate 128000
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int f0/0
R3(config-if)#ip ad
R3(config-if)#ip address 10.0.0.1 255.0.0.0
R3(config-if)#no shut
R3(config)#int f0/1
R3(config-if)#ip ad
R3(config-if)#ip address 172.30.0.1 255.255.0.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#router rip
R3(config)#network 172.30.0.0
R3(config)#network 172.18.0.0
R3(config)#network 10.0.0.0
R3(config)#network 202.110.10.0
R3(config)#network 172.16.0.0
R3(config)#network 192.168.0.0
R3(config)#network 192.168.1.0
R3(config)#end
R3#sh ip route

Kemudian jangan lupa untuk menkonfigurasi IP Address komputer client sesuai dengan topologi jaringan yang telah di design sebelumnya. Dan jangan lupa untuk melakukan test ping untuk memastikan koneksi antar network.

PC0>ping 172.30.0.2

Pinging 172.30.0.2 with 32 bytes of data:

Reply from 172.30.0.2: bytes=32 time=219ms TTL=125
Reply from 172.30.0.2: bytes=32 time=250ms TTL=125
Reply from 172.30.0.2: bytes=32 time=250ms TTL=125
Reply from 172.30.0.2: bytes=32 time=235ms TTL=125

Ping statistics for 172.30.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 219ms, Maximum = 250ms, Average = 238ms
PC0>tracert 172.30.0.2

Tracing route to 172.30.0.2 over a maximum of 30 hops:

1 63 ms 94 ms 78 ms 192.168.1.1
2 125 ms 125 ms 125 ms 202.110.10.2
3 156 ms 141 ms 125 ms 172.18.0.2
4 234 ms 218 ms 187 ms 172.30.0.2

Trace complete.

Dengan demikian sudah dapat kita hubungkan antara PC0 pada network 192.168.1.0/24 dengan network PC4 yang memiliki network 172.30.0.0/16, demikian juga untuk koneksi yang lain.

0 komentar:

Poskan Komentar

shoutchat


ShoutMix chat widget